wemaus

Font Size

Cpanel

Teil II, 23 cm FM-Transceiver

Im 2. Teil wird nun die Inbetriebnahme erläutert. Die Platine ist nun mit allen Teilen versehen.

Die Verdrahtung der Peripherie wird im meinem Fall mit kurzen Steckkabeln, einem Breadboard und mehreren Pfostensteckern, die lediglich mit leichtem Druck in die Kontakte der Platine gesteckt werden, ohne sie zu verlöten, durchgeführt. Am LCD wird für den Anschluss ebenfalls eine Pfostensteckerleiste verwendet, die aber gleich eingelötet wird.

In der folgenden Aufstellung werden die verschiedenen Ports und Anschlüsse des Transceivers beschrieben.

Portbelegung des ATMega:

  • PD0: In, /PTT
  • PD1: In, Shift, Umschaltung der Ablage
  • PD2: In, Push, Taste Drehgber
  • PD3: In, Rotary, Drehgeber
  • PD4: In, Rotary, Drehgeber
  • PD5: In, DN, zur Ansteuerung des Transceiver über Software bei Satellitenbetrie (Dopplershift)
  • PD6: In, UP, dito
  • PD7: Out, Ausgang um über ein Coax-Relais die PA zu steuern, aktiv Hight, 200 ms Verzögerung für Sendesignal

 

  • PB0: Out, E, LCD
  • PB1: Out, RS, LCD
  • PB2: Tone, S, extern
  • PB3: Out, CTCSS
  • PB4 .. PB7: D4 .. D7, Out, LCD

 

  • PC0: Out, CLK
  • PC1: Out, Data
  • PC2: Out, LE
  • PC3: Out, TXON
  • PC4: Out, Mute
  • PC5: In, RSSI

Anmerkung: Die Pinbelegungen PC0 und PC2 sind im Schaltplan V 4.0 vertauscht!

 

  • P1: Hubeinstellung
  • P2: Kontrast des LCD
  • P3: Lautstärke

 

Nach der Überprüfung der Verkabelung kann die Betriebsspannung mit eingeschalteter Strombegrenzung angelegt und vorsichtig erhöht werden. Die Stromaufnahme im Empfangsbetrieb beträgt ca. 210 mA bei 13,8 Volt.

Die Kontrasteinstellung für das LCD wird nun mit P2 durchgeführt. Dabei sollte das Gerät nun den VFO-Mode anzeigen. Eine Anzeige des S-Meters muss ohne Signal bei Null, also keine Balken sichtbar, liegen.

Jetzt sollten die verschiedenen Spannungen kontrolliert werden.

  • IC10: Pin 3/C39, 9 Volt
  • IC11: Pin 3, 5 Volt
  • ICxx: Pin 3, 3,3 Volt
  • D5: Kathode, 3,3 Volt
  • C53 rechts, 7,5 Volt

Sinnvoll ist nun noch die Frequenzen und Spannungen des TCXO und des 80 MHZ Oszilators zu prüfen. Die Spannung der Beiden liegt jeweils bei ca. 2,5 Vss.

Ist Alles soweit in Ordnung, kann mit der Funktionsüberprüfung fortgefahren werden.

 

Der Transceiver läuft!   Die erste Inbetriebnahme. Der Transceiver läuft, zeigt aber noch Auffälligkeiten. Das S-Meter zeigt Vollausschlag, ohne dass ein Signal angelegt ist.
     
Ein 69,3 MHz Testsignal wird eingekoppelt  

Hier wird ein Testsignal von 69,3 MHz lose eingekoppelt. Es wird mit 1 kHz moduliert, bei einem Hub von 2,8 kHz. Jetzt kann L4 auf maximale Spannung am Lautsprecherausgang abgestimmt werden. Auch hier zeigte sich, dass sich am Ausschlag des S-Meters nichts bewegte. Auch am Ausgangspin 28 (RSSI) des ATMega war keine Reaktion zu erkennen.

Dieser Zustand änderte sich erst nach einer Neuprogrammierung des Prozessors mit neu kompiliertem Sourcecode.

     
VCO-Signal   Ein weiteres Problem trat auf. Im VFO-Modus lies sich die Frequenz zwar in der Anzeige verstellen, aber der VCO reagierte in keiner Weise darauf und blieb wie festgenagelt auf der Frequenz 1182 MHz stehen. Auch am Messpunkt TP war lediglich nur ein Low-Pegel festzustellen, was darauf schließen lies, dass der PLL nicht einrastete. Etwas Positives war jedoch auch dieser Messung, Tastkopf des Spektrumanalyzers am oberen Anschlus von C48, abzugewinnen, denn dadurch zeigte es sich, dass zumindest der VCO läuft. Eine weitere Messung am CP-Ausgang (Ladungspumpe) der PLL ergab eine Spannung von 1,95 Volt. Dabei konnte auch festgestellt werden, dass sich die Frequenz des VCO's durch die Belastung an diesem Punkt änderte. (Blockschaltbild)
     
Abhängigkeit des VCO's von der Tuning-Spannung   Ein Vergleich der beiden Spannungen in Bezug auf den Frequenzsprung bestätigte diese Annahme. Links im Diagramm lässt sich dies anschaulich darstellen. Die grüne Kurve stamm aus dem Datenblatt des VCO (ALPS E-994A) und die rote Kurve zeigt den interpolierten Wert der gemessenen Spannung und Frequenz.

 

Nun gab es eigentlich nur noch zwei Möglichkeiten. Entweder war der PLL abgeraucht, oder hatte ein Problem mit der Kontaktierung, obwohl die bereits vorher geprüft wurde. Also nochmals nachsehen, das Flussmittel nochmal sauber entfernen. Dabei konnte unter dem Mikroskop festgestellt werden, dass sich der Pin 1 etwas bewegte und das war insofern ein Lichtblick, dass eher die Kontaktierung des IC's das Problem verursachte. Weitere Überprüfungen am IC zeigten weitere nicht sauber verlötete Pins.

Nachdem die betreffenden Pins nochmals sorgfältig verlötet wurden, funktionierte die PLL-Regelung wie erwartet. Durch zusätzliche Messungen war nun feststellbar, dass die Ausgabefrequenz des VCO's der Frequenzeinstellung des Transceivers korrekt folgte.

 

 

 

Links:

   
Teil I   Teil I, 23 cm Transceiver
     
Blockschaltbild pdf VCO-PLL
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.